10 способов использования функции Import XML для анализа страниц сайта

Читайте также:

комментариев 13

  1. Ваня:

    а как бороться с этим http://prntscr.com/eqq0nm ?

    • Есть определенный лимит запросов на один Google Spreadsheets. Я просто создаю новый гугл спредшитс, делаю часть запросов там, а в рабочий док вставляю только значения. Данный способ и не предназначен изначально для большого объема данных. Но для небольшого анализа подходит.

  2. Дмитрий:

    Скажите, а можно получить список всех ссылок на странице с анкорами этих ссылок? Чтобы можно было построить карту меню, например?
    Ищу полдня, и не могу найти как реализовать.

    • Здравствуйте. Можно.

      В одной ячейке пишите =IMPORTXML(«Ваш урл»; «//a/@href»), а в соседней клетке справа пишите =IMPORTXML(«Ваш урл»; «//a»),

      В итоге получите список урлов, а справа список анкоров

      • Владислав:

        Здравствуйте. Попробовал эту формулу. качает все меню, вообще все ссылки со страницы. а мне надо скачить только товары. возможно это? Спасибо

  3. Владислав:

    На нужной странице пишеч: Объем импортированных данных превышает допустимый.

  4. Артур:

    Вопрос такой, как обновить полученные данные? Т.е. один раз спарсили когда фомулу вставили, через 5мин/5 дней нужно обновить их. Есть мысли?

  5. Andre:

    Подскажите по 4 пункту..

    Задача забрать весь plain-text со страницы не прописывая class =ЕСЛИОШИБКА(ДЛСТР(СЦЕПИТЬ(IMPORTXML(A2;»//div[@class=’typo’]»)));»НЕ ВЕРНЫЙ CLASS»)

    Значем что текст стоит в основном в часть данных структурируются в таблицу .. какую тут формулу можно сконструировать? или как допились эту =ДЛСТР(СЦЕПИТЬ(IMPORTXML(A5;»//p))) что бы в данные вытягивало колличество слов из

    Спасибо.

  6. Govekax:

    Do you! need something new? Look at this site. Only there the choice of hot girls for every taste and completely free! They are good slaves, they will implement anything you command !
    http://gov.shortcm.li/kings#H28

  7. Govekax:

    Do you want something startup new? Open and look at this website. Only there the choice of girls for every desire and completely free! They are responsible slaves, they will implement anything you command !
    http://gov.shortcm.li/kings#R58

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *